Need Help Powertronic V4 Nightmare


New Member
Country flag
Bought a PT V4 w/ QS (used) new in box from someone in Canada (live in US). When receiving the unit it was very clear this unit had never left the box and know its genuine. I assumed (big mistake on my part) that since the warranty had not been activated that I could activate it. Communicated with the seller and they were unable to locate the invoice number from when they ordered it from PT. So, I was unable to activate the warranty via their link. I emailed PT and was informed that I could not validate the warranty because I was not the original purchaser. Aggravated but I should have figured that would be the case and should have checked prior instead of assuming. Although, I can understand not validating the warranty for defects and what not. I think its pretty crappy they will not provide me any support for the issue I am having. Even offering to pay for the assistance. I will most definitely not buy PT products in the future because of it.

On to the issue im having..

2015 ktm rc390
-Stock intake
-Stock injector
-Competion werkz underbelly exhaust W/ bristol core repack
-Fuel-X lite
-PT V4 w/ QS

Felt as if it was running a little on the lean side as expected with the addition of the exhaust. so i bought the Fuel-X lite new from PT. It definitely smoothed it out and felt as if it was running richer than w/o it. Although the power felt smooth and refined it lost its "aggression". Eventually stumbled across the new PT v4 for a great price. After installing it and verifying it was all plugged up correctly with the bypass that has lights on it, I performed the idle reset, TPS relearn, etc. Followed every step of the instructions on their website. Ran it on map 2 and noticed on decel that it popped alot so I tried map 1. Popping on decel was fkn ridiculous and right around 8k rpm 50-100% throttle it shuddered really bad and would stop accelerating until I rolled out of the throttle and carefully eased passed that spot allowing me to go WOT again. Looking at the maps (they are the standard map for my bike w/ QS) that is the richest part of the map. So I figured "eh, ill give the Fuel-X time to adjust". Now its even worse if i get in that region of the fuel map it completely stalls. Letting out of the throttle it fires back up. When this occurs if i pull the clutch in it completely shuts off. When in 3rd giving about 30% throttle at around 5-6k rpm it sputters extremely bad. This doesnt start occuring until a few miles down the road after sitting at a consistent throttle position. Almost as if more and more fuel is building up in the engine. Obviously its not but thats the best way I can explain it. When this has happens, if i pull the clutch in and let it completely stall out and come to a stop I have to let it sit a minute or so before trying to start it or it just cranks w/o starting. After playing with this crap for a bit I switched back to map 1. Now map one does the same crap but just not as severe. I am assuming this has to do with the adjustments made within the map of the Fuel-X lite. Fuel consumption has soared into the heavens. Exhaust smells a bit rich to me. So I have concluded these 2 standard maps they offer for it are steamy piles of crap. They even look extremely generic, as if 0 effort was put in to actually craft it for the 2015 rc390. I downloaded maps from the other year bikes (didnt burn them to my unit. Just viewed them) and they all look like what I would consider somewhat "customized". This is about the time I emailed PT about getting the warranty activated while at the same time describing my issue and requesting a map better suited for my bike with the exhaust it has. After being told the warranty was a no go. I offered to pay and requested a price for providing a map better suited for my bike. To which they completely stopped communicating with me. For the record I wasnt an ass in our communication and even expressed understanding pertaining to the warranty thing and communicated that I was appreciative of them getting back with me so fast about it. Im essentially stuck with an expensive paper weight atm. The closest dyno is 11hrs away from me. I contacted two people in my area that tune cars and have a dyno to see if they could get me a base map that is atleast better than what ive got and they are both so busy they dont want to mess with it.

Im sure that im leaving out many details pertaining to problem but its important to note that I can alter the problem with small alterations to the fuel maps. Also, when in R-tune and viewing the TPS while twisting the throttle it reaches 100% before i actually hit throttle limit. I estimate twisting an additional 10-20% after it reaches 100% in R-tune. I have redone the TPS relearn several times and it remains that way. Is this normal? as that may be part of the problem if its not. Im afraid to make any major adjustments to the map because although ive messed with tuning cars a tad I dont have a wideband AFR gauge on this bike which makes me feel uncomfortable with making changes myself. I have searched endlessly for other people sharing maps for the PT v4 and have found 0. not a single one. I have found plenty for the PT v1-v3.

additional note. I removed the Pt V4 plugged in the little tool that verifies everything is connected properly and rode with 0 issues also. So its not anything wrong with the bike or any of the connections. Its all caused by the PT v4 base maps provided by PT and like i said prior, altering the maps changes the issue.

Ill end this saga with some questions that im desperately needing answers to.
Going to a dyno is not realistic in my region or i would have done so already.
Can I manually transfer custom tunes from R-tune v3 to v4? (V3 and V4 maps are in different file formats) So open a v3 map in R-tune 3.0 and then open up R-tune 4.0. Then proceed to manually input the values viewed from the v3 map into the corresponding cells in v4. Is that possible or would that not work due to how it processes the information and scales it prior to outputting it to the ecu of the bike?
Has anyone else gotten the v4 and had this issue?
Is it running rich and flooding out or leaning out and stalling?
Anyway to read AFR through the OBD port?

Open to any and all suggestions! Ill add pictures of the maps as soon as I can.
Big thanks in advance!

Edit: Just dawned on me that i havent tried disconnecting the QS and riding it to see if the issue persist. I will try this next and update with results.

Update: Disconnecting QS did not resolve problem. Found the firmware had 2 updates available. Completed both updates and changed the spk noise filter from 0 to .2. Runs much better. Conditioned only occurred once during a 30min test ride. Ordered GA oversized injector. Currently looking for a dyno that accepts PT. Ive called every motorcycle dyno within 300 miles that I could find and none of them mess with PT, they only tune with power commander.
Last edited: